Please consider turning off your ad-blocking software for this site, and/or making a donation. As a charitable nonprofit we rely on this income to keep this site running.
Big thank-you hug!

High Point

  2079 Members   Please see the Member FAQ for help

Post ID: 71821934

WANTED: Need smart phone with at least Android 5.1

Location :High Point
Date : Sat Jun 8 16:42:08 2019

Description

Need a smart phone with at least Android 5.1, because the Amazon Alexa app has than minimum system requirement.

You need to be and a Member of this Group to reply to this Post

Please login or sign up to My Freecycle to join this group.